2021 is dedicated to the user - adding all the features an advanced user needs.

Ettus USRP X310 & SDR console

DF5VAE Charly
Posts: 8
Joined: Mon Jan 11, 2021 1:38 pm

Ettus USRP X310 & SDR console

#1

Unread post by DF5VAE Charly »

Hello & HNY to all

I had no problems installing and testing an ETTUS USRP-N200 with SDR console 3.0.26
using Win7/64 and latest UHD 4.0 hardware driver.

However unlike shown on a a picture from Simon my X310 with UBX160 is not found via SDR console (Ettus) search .
(both 32 & 64bit UHD 4.0 drivers are installed in their default directories)

Setup 1) x310 supplied adapter to connect SADR via 1G copper LAN (connected to port 0 of x310
Setup 2) using fiber connection (2x Intel FTLX857 & Intel networkadapter X520-DA2)
Fiber connection to port 0 or same setup with 10G fiber connection to port 0 and port 1.

The UBX board was in its unopened original packing when received a few day ago - but I have no means
to test the proper functionning of this x310 / UBX160 combination other then running the USRP probe command

The "probe" command works only if I specify the IP address of the unit as shown further down:

There may be an unknown reason or setup error as SDR console & UHD cannot identify the X310 as the same software setup works for either of my N200/WBX units.

73, Charly


c:\Program Files (x86)\National Instruments\NI-USRP\utilities>uhd_usrp_probe --args addr=192.168.10.2
_____________________________________________________
/
| Device: X-Series Device
| _____________________________________________________
| /
| | Mboard: X310
| | revision: 4
| | product: 30410
| | mac-addr0: 00:80:2f:0a:e9:f7
| | mac-addr1: 00:80:2f:0a:e9:f8
| | gateway: 192.168.10.1
| | ip-addr0: 192.168.10.2
| | subnet0: 255.255.255.0
| | ip-addr1: 192.168.20.2
| | subnet1: 255.255.255.0
| | ip-addr2: 192.168.30.2
| | subnet2: 255.255.255.0
| | ip-addr3: 192.168.40.2
| | subnet3: 255.255.255.0
| | serial: F4C00F
| | FW Version: 6.0
| | FPGA Version: 36.0
| | FPGA git hash: fde2a94
| | RFNoC capable: Yes
| |
| | Time sources: internal, external, gpsdo
| | Clock sources: internal, external, gpsdo
| | Sensors: ref_locked
| | _____________________________________________________
| | /
| | | RX Dboard: A
| | | ID: UBX-160 v1 (0x007a)
| | | Serial: 30C6978
| | | _____________________________________________________
| | | /
| | | | RX Frontend: 0
| | | | Name: UBX RX
| | | | Antennas: TX/RX, RX2, CAL
| | | | Sensors: lo_locked
| | | | Freq range: 10.000 to 6000.000 MHz
| | | | Gain range PGA0: 0.0 to 31.5 step 0.5 dB
| | | | Bandwidth range: 160000000.0 to 160000000.0 step 0.0 Hz
| | | | Connection Type: IQ
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Codec: A
| | | | Name: ads62p48
| | | | Gain range digital: 0.0 to 6.0 step 0.5 dB
| | _____________________________________________________
| | /
| | | RX Dboard: B
| | | ID: Basic RX (0x0001)
| | | Serial: E9R01ZDRB
| | | _____________________________________________________
| | | /
| | | | RX Frontend: AB
| | | | Name: BasicRX (AB)
| | | | Antennas: AB, BA, A, B
| | | | Sensors:
| | | | Freq range: -250.000 to 250.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 500000000.0 to 500000000.0 step 0.0 Hz
| | | | Connection Type: IQ
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Frontend: BA
| | | | Name: BasicRX (BA)
| | | | Antennas: AB, BA, A, B
| | | | Sensors:
| | | | Freq range: -250.000 to 250.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 500000000.0 to 500000000.0 step 0.0 Hz
| | | | Connection Type: QI
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Frontend: A
| | | | Name: BasicRX (A)
| | | | Antennas: AB, BA, A, B
| | | | Sensors:
| | | | Freq range: -250.000 to 250.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 250000000.0 to 250000000.0 step 0.0 Hz
| | | | Connection Type: I
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Frontend: B
| | | | Name: BasicRX (B)
| | | | Antennas: AB, BA, A, B
| | | | Sensors:
| | | | Freq range: -250.000 to 250.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 250000000.0 to 250000000.0 step 0.0 Hz
| | | | Connection Type: Q
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Codec: B
| | | | Name: ads62p48
| | | | Gain range digital: 0.0 to 6.0 step 0.5 dB
| | _____________________________________________________
| | /
| | | TX Dboard: A
| | | ID: UBX-160 v1 (0x0079)
| | | Serial: 30C6978
| | | _____________________________________________________
| | | /
| | | | TX Frontend: 0
| | | | Name: UBX TX
| | | | Antennas: TX/RX, CAL
| | | | Sensors: lo_locked
| | | | Freq range: 10.000 to 6000.000 MHz
| | | | Gain range PGA0: 0.0 to 31.5 step 0.5 dB
| | | | Bandwidth range: 160000000.0 to 160000000.0 step 0.0 Hz
| | | | Connection Type: QI
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | TX Codec: A
| | | | Name: ad9146
| | | | Gain Elements: None
| | _____________________________________________________
| | /
| | | TX Dboard: B
| | | _____________________________________________________
| | | /
| | | | TX Frontend: 0
| | | | Name: Unknown (0xffff) - 0
| | | | Antennas:
| | | | Sensors:
| | | | Freq range: 0.000 to 0.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 0.0 to 0.0 step 0.0 Hz
| | | | Connection Type: IQ
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | TX Codec: B
| | | | Name: ad9146
| | | | Gain Elements: None
| | _____________________________________________________
| | /
| | | RFNoC blocks on this device:
| | |
| | | * DmaFIFO_0
| | | * Radio_0
| | | * Radio_1
| | | * DDC_0
| | | * DDC_1
| | | * DUC_0
| | | * DUC_1


c:\Program Files (x86)\National Instruments\NI-USRP\utilities

User avatar
PD3LK
Posts: 276
Joined: Thu Aug 06, 2020 10:36 am

Re: Ettus USRP X310 & SDR console

#2

Unread post by PD3LK »

Hi Are you using DHCP or fixed IP assignments?
When fixed...how long is your subnet prefix lenght?
That must be 24, when smaller then use the range 192.168.10.2 - 192.168.10.X (not 192.168.20.X , 192.168.30.X , and so on)
(with other words, i suspect you're radio and SDRC are in different sub-nets)

DF5VAE Charly
Posts: 8
Joined: Mon Jan 11, 2021 1:38 pm

Re: Ettus USRP X310 & SDR console

#3

Unread post by DF5VAE Charly »

Hello Leon,
Thanks for your reply.

I use fixed IP assignments - PC side 192.169.10.1 & 255.255.255.0. Ettus x310 defauilt: 192.168.10.2
Network is using the mainboard Intel chip set (82579V) with latest Intel Win7 driver.
(Internet connection if needed is via an USB3 -network adapter 192.168.178.x)

(This setup works fine when connecting either Ettus N200 - 192.168.10.3 & 192.168.10.4) in subnet and with the same CAT7 cable.

However I can ping the x310 (from c prompt) without any problem.

One time only SDR console found the X310 and reported four fixed IP assignments
192.168.10.1
192.168.20.1
192.168.30.1
192.168.40.1
after I selected 192.168.10.1 (Port 0 - with supplied adapter to 1 G copper) SDR console indicated an error
since then no more results from x310 scan.

I re-installed SDR console and Ettus UHD driver (4.0) but still the same problems.

I dont like Intel (onboard) network chips - Often I have to disable & re-enable driver software to activate network - even though all energy saving etc functions are switched off.

I am pure software user - no dedicated skills. The x310 firmware is up to date. For the last tests I even remove the optical adapter from the pc.

73 Charly, DF5VAE

jdow
Posts: 235
Joined: Mon Aug 10, 2020 8:17 pm

Re: Ettus USRP X310 & SDR console

#4

Unread post by jdow »

Charly, do NOT use 192.169.x.y for an internal network connection. I hope that 192.169.10.1 is a typo. If not the people at hsrp-v10-sw-inet-edge.ochin.org are probably being annoyed.

I would recommend keeping all four assignments inside the same Class-C size network, 192.168.23.30, 192.168.23.32, 192.168.23.32, and 192.168.23.33, for example. Otherwise there may be some routing problems within your "campus".

{^_-}

DF5VAE Charly
Posts: 8
Joined: Mon Jan 11, 2021 1:38 pm

Re: Ettus USRP X310 & SDR console

#5

Unread post by DF5VAE Charly »

Hello "jdow"
You are right!
192.169 ist a typo - should have read 192.168.10.1 (for the PC Network card)

Just to be on the safe side I reflashed the x310 FPGA Ver. 38.0 & Firmware Ver. 6.0 with the latest UHD version 4.00 once again.
.
UHD "probe" command without address does not find the x310
UHD "probe" command with IP address finds the x310 ans daughterboard OK.
Pinging 192.168.10.2 complets successful.

This is an issue I cannot understand -
The x310 sends a "broadcast" roughly every 15 sec with correct IP ( verified with wireshark)

Regarding SDR_Console 3.0.26

++++++++++++++++
It seems SIMON is still using UDH version 3.15code not the recent UHD 4.00 if I read and interprete the SDR_Console logfile correctly.
With so many different SDR it is certainly time consuming to check all driver updated.

Until I sove these problems I'll continue to use one om my USRP N200 - they work well with SDR console and bandwith settings (under 20 MHz)

73,Charly, DF5VAE

ray
Posts: 2
Joined: Sun Aug 09, 2020 10:55 am

Re: Ettus USRP X310 & SDR console

#6

Unread post by ray »

Charly,

You are correct, Simon uses UHD version 3.15LTS.
He tried 4.0 but was not fully released at the time and it had bugs (I think). I suggest you image the X310 for UHD version 3.15LTS, it works fine with that on all the ports (depending on FPGA Build).

73,
Ray
WA1CYB

User avatar
PD3LK
Posts: 276
Joined: Thu Aug 06, 2020 10:36 am

Re: Ettus USRP X310 & SDR console

#7

Unread post by PD3LK »

Ok, you're setup is more clear to me now, i thought you made these fixed IP addresses yourself.
(192.168.10.1 - 192.168.20.1 - 192.168.30.1 - 192.168.40.1)

I remember that Simon changed something to the network discovery method somewhere in or before Q4 2020.
I'm not sure if it helps in any way but did you looked how older SDRC version act on the x310 discovery?

btw in my situation SDRC (or Thetis) can't find the Anan7k when i connect him to the network card in my PC while internetting on another networkcard or wifi, because of the different subnets. Lot's of how-to hints on internet but i gave up on further trying. Now i've connected the PC and Anan to a small/cheap hub (Netgear GS105), that works much better.

(sharp JD...sharp :)

DF5VAE Charly
Posts: 8
Joined: Mon Jan 11, 2021 1:38 pm

Re: Ettus USRP X310 & SDR console

#8

Unread post by DF5VAE Charly »

Hello ,
thanks Ray and Leon for your help

I downloaded the 64bit UHD version 3.15 and will flash the software correspondingly tomorrow afternoon.

Flashing should go quickly, I have created a few batch files to transfer the image & firmware.
At my age its easy to produce unnoticed typos...
.
May be one of you can let me know if the (UDH) probe command (in Win 7/64) should actually find an X310 without specifying its default IP address -
I receive a proper reply so far only when the IP address (192.168.10.2) is specified.

May be the x310 is too complex for me to play but it was tempting occasion as it covers a few of the SHF hambands -I used in the past with transverters. I try to learn as much as possible and activate the gray cells.

The PC I use to play test the Ettus setup has a network chip integrated on the mother board - it is set exclusively to communicate within the Ettus Netword address range.

Internet connection if needed is via an USB 3.0 Networkadapter (CSL brand) I can activate or decativate the Internet as needed. Easier for me than running two network cards.
73,
Charly DF5VAE

DF5VAE Charly
Posts: 8
Joined: Mon Jan 11, 2021 1:38 pm

Re: Ettus USRP X310 & SDR console

#9

Unread post by DF5VAE Charly »

Hello,
even more grey hairs ...

I have just reflashed my x310 with UHD Ver 3.15 (Image & firmware) - no error encountered and each time properly rebooted.
below the reults.
received one warning: [WARNING] [UDP] The MTU (1472) is larger than the FastSendDatagramThreshold (1024)!
(assume it is a network card setting - which should not effect the SDR console search.

x310 is still not recognised with 3.15 software by SDR console.


Next step: I will dismount the (brand new) UBX160 daughterboard and replace it with a spare LF RX board.

73, Charly DF5VAE

c:\Program Files\UHD315\bin>uhd_usrp_probe --args addr=192.168.10.2
[INFO] [UHD] Win32; Microsoft Visual C++ version 1920; Boost_107000; UHD_3.15.0.
0-release
[INFO] [X300] X300 initialization sequence...
[INFO] [X300] Maximum frame size: 4044 bytes.
[INFO] [X300] Radio 1x clock: 200 MHz
[WARNING] [UDP] The MTU (1472) is larger than the FastSendDatagramThreshold (1024)!
This will negatively affect the transmit performance.
See the transport application notes for more detail.

[INFO] [0/DmaFIFO_0] Initializing block control (NOC ID: 0xF1F0D00000000000)
[INFO] [0/DmaFIFO_0] BIST passed (Throughput: 1320 MB/s)
[INFO] [0/DmaFIFO_0] BIST passed (Throughput: 1315 MB/s)
[INFO] [0/Radio_0] Initializing block control (NOC ID: 0x12AD100000000001)
[INFO] [0/Radio_1] Initializing block control (NOC ID: 0x12AD100000000001)
[INFO] [0/DDC_0] Initializing block control (NOC ID: 0xDDC0000000000000)
[INFO] [0/DDC_1] Initializing block control (NOC ID: 0xDDC0000000000000)
[INFO] [0/DUC_0] Initializing block control (NOC ID: 0xD0C0000000000000)
[INFO] [0/DUC_1] Initializing block control (NOC ID: 0xD0C0000000000000)
_____________________________________________________
/
| Device: X-Series Device
| _____________________________________________________
| /
| | Mboard: X310
| | revision: 4
| | product: 30410
| | mac-addr0: 00:80:2f:0a:e9:f7
| | mac-addr1: 00:80:2f:0a:e9:f8
| | gateway: 192.168.10.1
| | ip-addr0: 192.168.10.2
| | subnet0: 255.255.255.0
| | ip-addr1: 192.168.20.2
| | subnet1: 255.255.255.0
| | ip-addr2: 192.168.30.2
| | subnet2: 255.255.255.0
| | ip-addr3: 192.168.40.2
| | subnet3: 255.255.255.0
| | serial: F4C00F
| | FW Version: 6.0
| | FPGA Version: 36.0
| | FPGA git hash: fde2a94
| | RFNoC capable: Yes
| |
| | Time sources: internal, external, gpsdo
| | Clock sources: internal, external, gpsdo
| | Sensors: ref_locked
| | _____________________________________________________
| | /
| | | RX Dboard: A
| | | ID: UBX-160 v1 (0x007a)
| | | Serial: 30C6978
| | | _____________________________________________________
| | | /
| | | | RX Frontend: 0
| | | | Name: UBX RX
| | | | Antennas: TX/RX, RX2, CAL
| | | | Sensors: lo_locked
| | | | Freq range: 10.000 to 6000.000 MHz
| | | | Gain range PGA0: 0.0 to 31.5 step 0.5 dB
| | | | Bandwidth range: 160000000.0 to 160000000.0 step 0.0 Hz
| | | | Connection Type: IQ
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Codec: A
| | | | Name: ads62p48
| | | | Gain range digital: 0.0 to 6.0 step 0.5 dB
| | _____________________________________________________
| | /
| | | RX Dboard: B
| | | _____________________________________________________
| | | /
| | | | RX Frontend: 0
| | | | Name: Unknown (0xffff) - 0
| | | | Antennas:
| | | | Sensors:
| | | | Freq range: 0.000 to 0.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 0.0 to 0.0 step 0.0 Hz
| | | | Connection Type: IQ
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | RX Codec: B
| | | | Name: ads62p48
| | | | Gain range digital: 0.0 to 6.0 step 0.5 dB
| | _____________________________________________________
| | /
| | | TX Dboard: A
| | | ID: UBX-160 v1 (0x0079)
| | | Serial: 30C6978
| | | _____________________________________________________
| | | /
| | | | TX Frontend: 0
| | | | Name: UBX TX
| | | | Antennas: TX/RX, CAL
| | | | Sensors: lo_locked
| | | | Freq range: 10.000 to 6000.000 MHz
| | | | Gain range PGA0: 0.0 to 31.5 step 0.5 dB
| | | | Bandwidth range: 160000000.0 to 160000000.0 step 0.0 Hz
| | | | Connection Type: QI
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | TX Codec: A
| | | | Name: ad9146
| | | | Gain Elements: None
| | _____________________________________________________
| | /
| | | TX Dboard: B
| | | _____________________________________________________
| | | /
| | | | TX Frontend: 0
| | | | Name: Unknown (0xffff) - 0
| | | | Antennas:
| | | | Sensors:
| | | | Freq range: 0.000 to 0.000 MHz
| | | | Gain Elements: None
| | | | Bandwidth range: 0.0 to 0.0 step 0.0 Hz
| | | | Connection Type: IQ
| | | | Uses LO offset: No
| | | _____________________________________________________
| | | /
| | | | TX Codec: B
| | | | Name: ad9146
| | | | Gain Elements: None
| | _____________________________________________________
| | /
| | | RFNoC blocks on this device:
| | |
| | | * DmaFIFO_0
| | | * Radio_0
| | | * Radio_1
| | | * DDC_0
| | | * DDC_1
| | | * DUC_0
| | | * DUC_1


c:\Program Files\UHD315\bin>

DF5VAE Charly
Posts: 8
Joined: Mon Jan 11, 2021 1:38 pm

Ettus USRP X310 & SDR console / 10G optical link

#10

Unread post by DF5VAE Charly »

Hello
In short:
I repeated all x310 setup tests using UHD ver. 3.15 with a 10G optical link (FPGA version HG, X310 network port 1 with its default IP: 192.168.40.2
Identical results.
Ping command succesful.
As before with a 1G copper link the HD probe command works fine when adding the IP address and recognises all spare daughterboards availabe here.

Again some hints were given by UHD about Paketsize (MTU) not optimised for max throughput in my 10G optical setup as I use its default settings.

As my software skills are far too limited to gain more information from further testing, I'll put the x310 aside until some one else reports successful testing of his USRP x310 with SDR console.

My preliminary conclusions:
SDR console finds and works ok with an Ettus USRP N200 flashed with either UHD 3.15 or UHD 4.0 hardware driver, image & Firmware.
It seems there is no problem to to upgrade (flash) to the recent UHD 4.00 hardware driver and firmware/images.

Thanks & happy new year
Charly, DF5VAE

Post Reply