Version 3.1 was released on Monday, August 2nd 2021. Now back to user requests.

Is the BladeRf V1 supported by Console 3.0.26

richhas
Posts: 6
Joined: Sat Jan 23, 2021 7:49 pm

Is the BladeRf V1 supported by Console 3.0.26

#1

Unread post by richhas »

I'm a VERY new Console user. I have a functional BladeRF + an XB200 with the following bits installed:

bladeRF-cli version: 1.8.0
libbladeRF version: 2.2.1

Firmware version: 2.0.0
FPGA version: 0.11.0

Should this radio work? When trying to Select Radio via Search, I select BladeRF v1 but get the error "Nothing Found - sorry".

Not sure this radio is actually supported as I don't see much info on the forums wrt the bladerf, if I must do some additional setup, or...

Is this radio supported?

I don't want to burn time if not so.

Thanks,

Rich

Max
Posts: 391
Joined: Thu Aug 13, 2020 9:47 am

Re: Is the BladeRf V1 supported by Console 3.0.26

#2

Unread post by Max »

Hi Rich

Was hoping someone with BladeRF would chime in but seems not! I have seen references to the BladeRF in the old forum at IO Groups so I assume it does work.

Does this post throw any light? I think this relates to SDR Console V2 but the same advice may apply?
https://sdr-radio.groups.io/g/main/topic/5713555#27732

Don't give up because the rewards are worth it. SDR Console is the best SDR software by some margin IMHO.

Best

Max

richhas
Posts: 6
Joined: Sat Jan 23, 2021 7:49 pm

Re: Is the BladeRf V1 supported by Console 3.0.26

#3

Unread post by richhas »

Thanks Max for the reply. I was hoping at least the bladerf folks would have responded. I been able to write c++ code against the current bladerf on win10 and it works. The Console distro has what appears to be the bladerf plugin dlls in the Console distro.

My main thing is getting any indication that there's a path at all. So the thread you pointed me to gave some hope.

Do you know where the official plugin dev docs are for Console?

Thanks again

Post Reply