Version 3.1 beta updated November 9th, 2021. Now working on the website and other infrastructure for the rest of November.

RX888 Mk2 has died after 2 weeks use :(

✔ Now supported, kit available by the end of September 2020.
m1ctk_dave
Posts: 1
Joined: Tue Nov 23, 2021 10:03 am

RX888 Mk2 has died after 2 weeks use :(

#1

Unread post by m1ctk_dave »

The green LED shows but no receive life from Console, SDR sharp or HDSDR :( Has anyone had the same experience ? It was working so well I am rather fed up about this and not sure I can get a refund either

rainstar
Posts: 39
Joined: Sat Dec 19, 2020 4:06 am

Re: RX888 Mk2 has died after 2 weeks use :(

#2

Unread post by rainstar »

Because of the risk of system damage from EMF discharge(lightening and the like) I usually run my SDR devices with an affordable Receiver Front End Protection Unit.
These are 1:1 baluns with a gas suppression diode lead connected to a ground terminal, and they function to protect my radio from EMF when used appropriately.
If your device has failed because of EMF it is an expensive lesson, but please understand that this is an issue faced by 99% of SDR products.

If you cannot achieve resolution of your issue by replacing cables and computers and firmware, I suggest opening the device very carefully and looking for any signs of burn marks.
These may be components you can replace. Repairing your own SDR is not necessarily a difficult choice, this particular open source design is very repairable.

Max
Posts: 421
Joined: Thu Aug 13, 2020 9:47 am

Re: RX888 Mk2 has died after 2 weeks use :(

#3

Unread post by Max »

m1ctk_dave wrote:
Tue Nov 23, 2021 10:09 am
The green LED shows but no receive life from Console, SDR sharp or HDSDR :( Has anyone had the same experience ? It was working so well I am rather fed up about this and not sure I can get a refund either
Any update on this Dave? Contact with seller?

Max

jdow
Posts: 484
Joined: Mon Aug 10, 2020 8:17 pm

Re: RX888 Mk2 has died after 2 weeks use :(

#4

Unread post by jdow »

It might help a TINY bit if the symptoms were better defined. For instance is the device found by HDSDR or SDRC? If it is found what happens when you hit the start button? Is it numb. Does it refuse to run?

With an incomplete problem description how is anybody supposed to help him?

{o.o}

Post Reply