RX-888 Mk2 not working

✔ Now supported, kit available by the end of September 2020.
Posts: 8
Joined: Sun Aug 09, 2020 11:24 am

RX-888 Mk2 not working


Unread post by mstangelo »

I occasionally use my RX-888 Mk2. I just loaded Simons's latest v3.2 SDRC software and tried it out. The RX-888 Mk2 was not discovered. I tried my original RX-888 ad that is working. I believe the hardware has issues.

Can anyone suggest any troubleshooting tips for my Mk2?

All of my SDR receiver is fed by and active W8ZR HF Multicoupler so I don't suspect EMI issues via the antenna port. I once kept it powered up for a couple of hours so heat may have damaged a chip.

I like viewing a wide portion of bandwidth 8 to 32 Mhz. Could anyone suggest another SDR which can receive a wide spectrum at a reasonable price. Are there any new products coming onto the market this year?

If I elect to buy another RX-888 Mk2 can anyone recommend a reputable vendor?

Thanks, Mike N2MS

Posts: 579
Joined: Mon Aug 10, 2020 8:17 pm

Re: RX-888 Mk2 not working


Unread post by jdow »

I've been threatening to create a source dll for that beast. (I have one.) Other things keep getting in the way. I have all the RX888 end of things under control, even if multiple rx888 devices are connected. I need to fumble through the source dll part of the picture.

Posts: 13
Joined: Wed Aug 19, 2020 4:20 pm

Re: RX-888 Mk2 not working


Unread post by Radioman »

I can only use 1MHz bandwidth on my RX888 in sdr radio or stutter occurs. On the same pc I can use 25Mhz bandwidth with HDSDR software.
Steve M0ZEH

Post Reply